第16届北京科音初级量子化学培训班将于10月3~6日于北京举行,是量子化学初学者迅速、正确上手计算的最佳机会!详情请点击此链接查看,欢迎参加!

计算化学公社

 找回密码
 现在注册!
查看: 4417|回复: 7

[综合交流] 求助关于服务器中cmake安装的问题

[复制链接]

377

帖子

0

威望

1680

eV
积分
2057

Level 5 (御坂)

尊贵的地三鲜骑士

发表于 2019-1-2 16:38:20 | 显示全部楼层 |阅读模式
目前服务器中系统为redhat且不能联网,系统中的cmake为2.8.12,而安装gromacs需要更高的版本。我以前在虚拟机中安装的是3.12.1版本,按照平常操作安装后却出现以下问题,CMake 3.12.1, Copyright 2000-2018 Kitware, Inc. and ContributorsFound GNU toolchain
C compiler on this system is: gcc      
---------------------------------------------
Error when bootstrapping CMake:
Cannot find a C++ compiler that supports both C++11 and the specified C++ flags.
Please specify one using environment variable CXX.
The C++ flags are "".
They can be changed using the environment variable CXXFLAGS.
See cmake_bootstrap.log for compilers attempted.
---------------------------------------------
Log of errors: /home/hzx/安装包/cmake-3.12.1/Bootstrap.cmk/cmake_bootstrap.log
请问各位老师,我应该如何处理解决cmake的安装呢?


由衷的感谢每一位给与过我帮助的人

10

帖子

0

威望

609

eV
积分
619

Level 4 (黑子)

发表于 2019-1-2 17:08:06 | 显示全部楼层
应该是机子太老了,先装gcc-c++.  CentOS下命令应该是 yum install make cmake gcc-c++,要root权限

377

帖子

0

威望

1680

eV
积分
2057

Level 5 (御坂)

尊贵的地三鲜骑士

 楼主| 发表于 2019-1-2 17:40:14 | 显示全部楼层
郑汉良很潇洒 发表于 2019-1-2 17:08
应该是机子太老了,先装gcc-c++.  CentOS下命令应该是 yum install make cmake gcc-c++,要root权限

非常感谢您的回复!服务器是redhat,输入命令后系统反馈是
Loaded plugins: aliases, changelog, downloadonly, kabi, presto, product-id, refresh-packagekit, security, subscription-manager, tmprepo, verify, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Loading support for Red Hat kernel ABI
Setting up Install Process
Nothing to do
这样的回答,您还有什么见解吗?机子确实好多年了
由衷的感谢每一位给与过我帮助的人

10

帖子

0

威望

609

eV
积分
619

Level 4 (黑子)

发表于 2019-1-2 18:35:46 | 显示全部楼层
少年爱吃地三鲜 发表于 2019-1-2 17:40
非常感谢您的回复!服务器是redhat,输入命令后系统反馈是
Loaded plugins: aliases, changelog, downlo ...

使用redhat的yum源是需要注册付费的。。而且yum要联网下载的。。没联网的话就得自己手动下载安装了,这个我不会了,等大神回复吧

377

帖子

0

威望

1680

eV
积分
2057

Level 5 (御坂)

尊贵的地三鲜骑士

 楼主| 发表于 2019-1-2 18:48:47 | 显示全部楼层
郑汉良很潇洒 发表于 2019-1-2 18:35
使用redhat的yum源是需要注册付费的。。而且yum要联网下载的。。没联网的话就得自己手动下载安装了,这个 ...

老师,我刚刚看了sob老师的一个帖子,我觉得可能我的版本太高了,我现在尝试低版本的安装,成功了告诉您。
由衷的感谢每一位给与过我帮助的人

113

帖子

0

威望

1865

eV
积分
1978

Level 5 (御坂)

发表于 2019-1-2 21:32:07 | 显示全部楼层
少年爱吃地三鲜 发表于 2019-1-2 18:48
老师,我刚刚看了sob老师的一个帖子,我觉得可能我的版本太高了,我现在尝试低版本的安装,成功了告诉您 ...

没联网的话比较麻烦,yum用不了,你可以自己下载编译好的二进制的CMake进行安装,前面你自己编译CMake3.12出错应该是g++没有安装或者g++版本太老的缘故。

113

帖子

0

威望

1865

eV
积分
1978

Level 5 (御坂)

发表于 2019-1-2 21:37:17 | 显示全部楼层
分享一个我之前下载的编译好的CMake3.13的吧,需要的同学自取
链接:https://pan.baidu.com/s/1c7JHyBepy3Wh2KM8Avcu3w 密码:62ix

.tar.gz结尾的是源码包,版本稍微新一点3.13.1
二进制安装包是.sh结尾的,下载后传到linux上,然后直接执行./cmake-3.13.0-Linux-x86_64.sh即可安装,对于编译有问题的同学建议使用二进制版直接安装

377

帖子

0

威望

1680

eV
积分
2057

Level 5 (御坂)

尊贵的地三鲜骑士

 楼主| 发表于 2019-1-3 15:07:27 | 显示全部楼层
gsbear 发表于 2019-1-2 21:37
分享一个我之前下载的编译好的CMake3.13的吧,需要的同学自取
链接:https://pan.baidu.com/s/1c7JHyBepy3 ...

非常感谢您的回复!!! 非常实惠! 我的解决办法是:我没有哟新的 我用本机自带的cmake 虽然版本较低,但是我把我的gromacs版本也低一下就可以安装,目前只有一个问题就是,本机自带的cmake,找不到他的文件夹,设置不了环境变量,但是应该能解决,非常感谢您!
由衷的感谢每一位给与过我帮助的人
您需要登录后才可以回帖 登录 | 现在注册!

本版积分规则

手机版|小黑屋|北京科音自然科学研究中心|京公网安备 11010502035419号|计算化学公社 — 北京科音旗下高水平计算化学交流论坛 ( 京ICP备14038949号-1 )

GMT+8, 2021-9-25 23:44 , Processed in 0.230480 second(s), 24 queries .

快速回复 返回顶部 返回列表