请选择 进入手机版 | 继续访问电脑版

计算化学公社

 找回密码
 现在注册!
查看: 681|回复: 9

[Linux] 安装g09提示'GLIBC_2.7' not found错误

[复制链接]

31

帖子

0

威望

202

eV
积分
233

Level 3 能力者

发表于 2018-1-19 11:07:13 | 显示全部楼层 |阅读模式
大家好,我在试着安装高斯09E01和D01时,提示g09:/lib64/libc.so.6: version 'GLIBC_2.7' not found (required by g09)。 安装不成功,g09A01没问题。大致意思是更新glibc-2.7,怎么更新?或者说还没有有其它更方便的办法,比如安装更新的linux操作系统?请大家不吝赐教,谢谢!

2203

帖子

23

威望

7431

eV
积分
10094

Level 6 (一方通行)

发表于 2018-1-19 11:21:29 | 显示全部楼层
最好的是装新的Linux

128

帖子

2

威望

1212

eV
积分
1380

Level 4 (黑子)

发表于 2018-1-19 11:26:29 | 显示全部楼层
换成新版Linux(CentOS 6以上),最好不要自己更新glibc.
之前曾经在超算上尝试自己更新glibc,还是按照工作人员给的指南来做的,然后整个系统都坏掉了。

31

帖子

0

威望

202

eV
积分
233

Level 3 能力者

 楼主| 发表于 2018-1-19 11:57:50 | 显示全部楼层
liyuanhe211 发表于 2018-1-19 11:21
最好的是装新的Linux

谢谢!

31

帖子

0

威望

202

eV
积分
233

Level 3 能力者

 楼主| 发表于 2018-1-19 11:58:21 | 显示全部楼层
Accelerator 发表于 2018-1-19 11:26
换成新版Linux(CentOS 6以上),最好不要自己更新glibc.
之前曾经在超算上尝试自己更新glibc,还是按照工 ...

谢谢!

194

帖子

4

威望

1634

eV
积分
1908

Level 5 (御坂)

发表于 2018-1-19 14:47:30 | 显示全部楼层
重装系统。

glibc是一个非常底层的库,还是二进制文件。改动了它,整个上层都得动大手术,九成九会挂掉。

31

帖子

0

威望

202

eV
积分
233

Level 3 能力者

 楼主| 发表于 2018-1-20 20:43:52 | 显示全部楼层
万里云 发表于 2018-1-19 14:47
重装系统。

glibc是一个非常底层的库,还是二进制文件。改动了它,整个上层都得动大手术,九成九会挂掉 ...

好的,谢谢!

140

帖子

0

威望

882

eV
积分
1022

Level 4 (黑子)

发表于 2018-1-21 23:11:35 | 显示全部楼层
应该不用安装的,自己下载 glibc-2.17 ,解压,放在自己的目录下,不用管理员权限。

设置环境变量
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/path to 放 .so 文件的目录

可以写入 ~/.bashrc,  source ~/.bashrc,或者 添加进运行 g09 的脚本。



评分

参与人数 1eV +3 收起 理由
jctyp + 3

查看全部评分

31

帖子

0

威望

202

eV
积分
233

Level 3 能力者

 楼主| 发表于 2018-1-23 12:07:15 | 显示全部楼层
北纬18° 发表于 2018-1-21 23:11
应该不用安装的,自己下载 glibc-2.17 ,解压,放在自己的目录下,不用管理员权限。

设置环境变量

好好,我试试,谢谢!

12

帖子

0

威望

52

eV
积分
64

Level 2 能力者

发表于 2018-5-20 21:13:48 | 显示全部楼层
glibc 这东西没救。换系统吧。
您需要登录后才可以回帖 登录 | 现在注册!

本版积分规则

手机版|北京科音自然科学研究中心|京公网安备 11010502035419号|计算化学公社 — 北京科音旗下高水平计算化学交流论坛 ( 京ICP备14038949-1号 )

GMT+8, 2018-8-21 02:31 , Processed in 0.244696 second(s), 24 queries .

快速回复 返回顶部 返回列表