计算化学公社

 找回密码 Forget password
 注册 Register
楼主 Author: youyno

[VASP] 教你从头编译vasp-5.4.1

  [复制链接 Copy URL]

10

帖子

0

威望

103

eV
积分
113

Level 2 能力者

发表于 Post on 2018-4-18 10:32:34 | 显示全部楼层 Show all
补充一下  我的系统是centOS 7.0 然后我在安装openmpi的时候版本不支持我安装的openmpi-3.0.1就这些不同
我不用把所有的文件都检查一边吧

多谢多谢

205

帖子

1

威望

3736

eV
积分
3961

Level 5 (御坂)

发表于 Post on 2018-4-18 16:25:06 | 显示全部楼层 Show all
du19880425 发表于 2018-4-18 02:27
你好多谢,刚用这个系统,前面的问题解决了
但是我在安装VASP5.4.1时按照教程上面做出现错误提示
[root ...

不好意思啊,你的这个我也不懂,我也就会按照楼主的方法装上。

1 如果你对Linux懂得多的话,弄几天估计也能编译出来;
2 要么就原原本本按照楼主的方法,一会儿就编译成功了;
3 或者花钱找人远程给你安装。

10

帖子

0

威望

103

eV
积分
113

Level 2 能力者

发表于 Post on 2018-4-18 19:39:34 | 显示全部楼层 Show all
bomsaude 发表于 2018-4-18 16:25
不好意思啊,你的这个我也不懂,我也就会按照楼主的方法装上。

1 如果你对Linux懂得多的话,弄几天估 ...

好了  我忍不住从新弄了下这次成功了  多谢

200

帖子

0

威望

3416

eV
积分
3616

Level 5 (御坂)

发表于 Post on 2018-4-19 16:44:37 | 显示全部楼层 Show all
du19880425 发表于 2018-4-18 19:39
好了  我忍不住从新弄了下这次成功了  多谢

请问您是用Centos 7安装的吗?

10

帖子

0

威望

103

eV
积分
113

Level 2 能力者

发表于 Post on 2018-4-23 09:35:44 | 显示全部楼层 Show all
1130240115 发表于 2018-4-19 16:44
请问您是用Centos 7安装的吗?

不是,还是按照楼主说的 老老实实的了

200

帖子

0

威望

3416

eV
积分
3616

Level 5 (御坂)

发表于 Post on 2018-4-23 11:09:03 | 显示全部楼层 Show all
确实,得按照楼主说的去做。其中,发现第一步最容易出错,得安装libgcc,glibc,libstdc++,这三个库直接yum install就可以了。而且,这些还要安装32位库,我参考的是这网址https://www.ggdoc.com/Y2VudG9zIH ... iMTllOGI5ZjZiYTY10/ 安的32位库

199

帖子

3

威望

3751

eV
积分
4010

Level 6 (一方通行)

 楼主 Author| 发表于 Post on 2018-4-23 17:00:17 | 显示全部楼层 Show all
1130240115 发表于 2018-4-23 11:09
确实,得按照楼主说的去做。其中,发现第一步最容易出错,得安装libgcc,glibc,libstdc++,这三个库直接yu ...

这些库在装系统的时候就应该装上的
Monte Carlo

200

帖子

0

威望

3416

eV
积分
3616

Level 5 (御坂)

发表于 Post on 2018-4-23 17:11:39 | 显示全部楼层 Show all
是的,老师,这些都很常用。但我在网上看的教程装的系统,网上教程没提到,装了好久才找到原因。

2

帖子

0

威望

11

eV
积分
13

Level 1 能力者

发表于 Post on 2018-4-26 21:04:28 | 显示全部楼层 Show all
本帖最后由 svdn 于 2018-4-26 22:07 编辑
xylz6188 发表于 2017-10-30 13:02
楼主您好。我在安装intel编译器时出现了一点困惑。您说在选择license时,以license文件进行验证,在需要输 ...
请问有没有可以用的yum源,系统缺少libstdc++ glibc libgcc ,可是yum无法检索资源库

205

帖子

1

威望

3736

eV
积分
3961

Level 5 (御坂)

发表于 Post on 2018-4-27 00:12:27 | 显示全部楼层 Show all
svdn 发表于 2018-4-26 13:04
请问有没有可以用的yum源,系统缺少libstdc++ glibc libgcc ,可是yum无法检索资源库

root下,安装libstdc++.i686, glibc.i686, libgcc.i686和gcc-c++试试看,最后一个是否必须不清楚。

2

帖子

0

威望

11

eV
积分
13

Level 1 能力者

发表于 Post on 2018-4-27 11:14:55 | 显示全部楼层 Show all
本帖最后由 svdn 于 2018-4-27 15:45 编辑
bomsaude 发表于 2018-4-27 00:12
root下,安装libstdc++.i686, glibc.i686, libgcc.i686和gcc-c++试试看,最后一个是否必须不清楚。

你好,我使用的ubuntu18.04,通过apt下载 libstdc++6,glibc-doc,libgcc-6-dev-ppc64-cross,以及gcc,不知道这些不同版本对安装有什么影响,在intel l编译时accept后



Do you agree to be bound by the terms and conditions of this license agreement?
Type "accept" to continue or "decline" to back to the previous menu: accept
./install.sh: 行 516: 11672 段错误               (核心已转储) $pset_engine_binary --tmp-dir=$user_tmp --log-file=$log_file $silent_params $duplicate_params $params --PACKAGE_DIR=$fullpath

请问会是什么原因?

10

帖子

0

威望

103

eV
积分
113

Level 2 能力者

发表于 Post on 2018-4-28 09:23:24 | 显示全部楼层 Show all
svdn 发表于 2018-4-27 11:14
你好,我使用的ubuntu18.04,通过apt下载 libstdc++6,glibc-doc,libgcc-6-dev-ppc64-cross,以及gcc, ...

这个就是说在安装文件.sh的时候哪里发生了错误,其实你也不知到文件和系统怎么个关系,所以还是按照楼主说的用CentOS6操作系统安装吧

3

帖子

0

威望

45

eV
积分
48

Level 2 能力者

发表于 Post on 2018-5-5 18:55:42 | 显示全部楼层 Show all
啊啊啊,楼主还在吗?按照教程一步一步走,在编译“fftw”的时候,configure遇到了“could not find mpi library for --enable-mpi”,这个不是个例,网上也有人在反馈用楼主的方法遇到相同的问题,上一步openmpi安装没问题的,which mpif90也正常。如果不开启enable mpi,编译fftw就没有问题。。

3

帖子

0

威望

45

eV
积分
48

Level 2 能力者

发表于 Post on 2018-5-5 19:05:23 | 显示全部楼层 Show all
....
shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... no
checking whether to build static libraries... yes
checking for ocamlbuild... no
checking for mpicc... mpicc
checking for MPI_Init... no
checking for MPI_Init in -lmpi... no
checking for MPI_Init in -lmpich... no
configure: error: could not find mpi library for --enable-mpi

9

帖子

0

威望

193

eV
积分
202

Level 3 能力者

发表于 Post on 2018-5-14 21:52:41 | 显示全部楼层 Show all
1130240115 发表于 2018-4-23 11:09
确实,得按照楼主说的去做。其中,发现第一步最容易出错,得安装libgcc,glibc,libstdc++,这三个库直接yu ...

您好,请问libgcc,glibc,libstdc++这三个库要怎么安装,谢谢!

本版积分规则 Credits rule

手机版 Mobile version|北京科音自然科学研究中心 Beijing Kein Research Center for Natural Sciences|京公网安备 11010502035419号|计算化学公社 — 北京科音旗下高水平计算化学交流论坛 ( 京ICP备14038949号-1 )

GMT+8, 2021-12-1 22:45 , Processed in 0.242190 second(s), 28 queries .

快速回复 返回顶部 返回列表 Return to list